net.shibboleth.utilities.java.support.component.*

Ian Young ian at iay.org.uk
Tue Feb 18 10:34:02 EST 2014


On 18 Feb 2014, at 15:23, "Cantor, Scott" <cantor.2 at osu.edu> wrote:
> 
>> On 2/18/14, 4:26 AM, "Rod Widdowson" <rdw at steadingsoftware.com> wrote:
>> 
>> So I'll go with what the group decides.  People with opinions should chip
>> in
>> now, but just for clarity you want
>> 
>> Identified to carry 'setId()'
>> Identifiable to carry 'getId()'
>> 
>> Not the other way around?
> 
> I don't care that much because I think having one without the other is
> quite unusual, but FWIW, I think those terms strike me as backwards. If
> it's identified, I think of it as having an ID I can get, and if it's
> identifiable, I think of it as something I can identify (that is assign a
> name to).
> 
> Nameable is fine by me, and frankly Nameable and Named seem clearer and
> shorter.

FWIW, +1 on both of the above paragraphs from me. I think I like Nameable/Named a little better except for the suspicion that this convention might imply getName, which I don't like much. 

   -- Ian, in transit
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2318 bytes
Desc: not available
Url : http://shibboleth.net/pipermail/dev/attachments/20140218/11f8eab9/attachment.bin 


More information about the dev mailing list