net.shibboleth.utilities.java.support.component.*

Cantor, Scott cantor.2 at osu.edu
Tue Feb 18 10:23:47 EST 2014


On 2/18/14, 4:26 AM, "Rod Widdowson" <rdw at steadingsoftware.com> wrote:
>
>So I'll go with what the group decides.  People with opinions should chip
>in
>now, but just for clarity you want
>
>Identified to carry 'setId()'
>Identifiable to carry 'getId()'
>
>Not the other way around?

I don't care that much because I think having one without the other is
quite unusual, but FWIW, I think those terms strike me as backwards. If
it's identified, I think of it as having an ID I can get, and if it's
identifiable, I think of it as something I can identify (that is assign a
name to).

Nameable is fine by me, and frankly Nameable and Named seem clearer and
shorter.

-- Scott




More information about the dev mailing list