coding conventions : getUrl vs getURL

Cantor, Scott cantor.2 at osu.edu
Mon Mar 11 22:39:39 EDT 2013


Since you asked...

On 3/11/13 10:33 PM, "Tom Zeller" <tzeller at dragonacea.biz> wrote:

>How about :
>
>a) getUrl or getURL

I favor getURL on the basis that the acronym is URL, not Url. As is SAML,
not Saml, SOAP not Soap, etc. I prefer to call things what they are than
try and remember to call them something else.

A lesser consideration is the preponderance of existing code, but I know
some of the OpenSAML stuff has also changed in v3 already, so there's
probably work either way.

>b) apply convention to new files only or new files and existing
>
>c) convention may be project specific

I favor consistency, and I think we need to avoid project specific rules
because for a period of time we may be moving code back and forth.

-- Scott




More information about the dev mailing list