RelyingPartyOverrides

Michael O Holstein michael.holstein at csuohio.edu
Mon Mar 23 23:29:17 EDT 2015


I've been trying to make sense of this looking at the various classes but .. again the revised config from the wiki (https://wiki.shibboleth.net/confluence/display/IDP30/SecurityConfiguration?), again attempted verbatim, causes the following error :


Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'shibboleth.RelyingPartyOverrides': Cannot create inner bean 'RelyingPartyByName$child#4d2c754' of type [net.shibboleth.idp.saml.relyingparty.impl.RelyingPartyConfigurationSupport] while setting bean property 'sourceList' with key [0]; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'RelyingPartyByName$child#4d2c754' defined in file [/usr/local/shib3/conf/relying-party.xml]: Cannot create inner bean 'Shibboleth.SSO$child#752cd083' of type [net.shibboleth.idp.saml.saml1.profile.config.BrowserSSOProfileConfiguration] while setting bean property 'profileConfigurations' with key [0]; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'Shibboleth.SSO$child#752cd083' defined in file [/usr/local/shib3/conf/relying-party.xml]: Initialization of bean failed; nested exception is org.springframework.beans.ConversionNotSupportedException: Failed to convert property value of type 'org.opensaml.xmlsec.impl.BasicSignatureSigningConfiguration' to required type 'net.shibboleth.idp.profile.config.SecurityConfiguration' for property 'securityConfiguration'; nested exception is java.lang.IllegalStateException: Cannot convert value of type [org.opensaml.xmlsec.impl.BasicSignatureSigningConfiguration] to required type [net.shibboleth.idp.profile.config.SecurityConfiguration] for property 'securityConfiguration': no matching editors or conversion strategy found

at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveInnerBean(BeanDefinitionValueResolver.java:313)


Thanks,


Michael Holstein

Cleveland State University


________________________________
From: users-bounces at shibboleth.net <users-bounces at shibboleth.net> on behalf of Brent Putman <putmanb at georgetown.edu>
Sent: Monday, March 23, 2015 5:20 PM
To: users at shibboleth.net
Subject: Re: RelyingPartyOverrides



On 3/23/15 4:55 PM, Cantor, Scott wrote:


I took another pass. I don't have a quick way to verify the wiring right now, maybe somebody else can if it's still wrong.

I think I've fixed the wiki example.  Essentially the SecurityConfiguration property for the signing config should be named signatureSigningConfiguration  rather than signingConfiguration.


(In case anyone is wondering about the more verbose name, it's because "ValidationConfiguration" is ambiguous, so I chose "SignatureValidationConfiguration" to disambiguate.  To keep things parallel, the complementary config is "SignatureSigningConfiguration" rather than just "SigningConfiguration".  In hindsight perhaps the latter would have been OK, but that's not what I did.)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://shibboleth.net/pipermail/users/attachments/20150324/377e13e3/attachment.html 


More information about the users mailing list