Discussion and voting: Coding convention : getLdapUrl or getLDAPURL ?
Tom Zeller
tzeller at dragonacea.biz
Tue May 21 11:26:32 EDT 2013
>> So discuss away.
>
> I am being entirely honest when I say I strongly dislike camel case acronyms, and I find it less easy on the eyes than all caps, because it doesn't read naturally to me. I don't like camel case if the words aren't words. I truly favor getLDAPURL and find it easier to look at and understand.
>
> But I'm fairly aware that Java has a pretty strong bias toward camel case, so if we're willing to do the refactoring then it seems clear that's the right choice. Among the things about Java that bug me, this isn't all that high on the list really, so I can deal.
I am on-the-fence regarding camel vs upper case, deferring by default to camel.
The following is a re-format of a recent post to shib-users, and makes
me think about being consistent across the configuration. Formatting
one attribute per line makes it easier to read, I think.
We've got a mix of cases.
<!-- Distinguish the values of employeeNumber from EDIR & AD -->
<resolver:AttributeDefinition
id="EDIRemployeeNumber"
xsi:type="Simple"
xmlns="urn:mace:shibboleth:2.0:resolver:ad"
sourceAttributeID="employeeNumber">
<resolver:Dependency ref="myLDAP" />
<resolver:AttributeEncoder
xsi:type="SAML1XMLObject"
xmlns="urn:mace:shibboleth:2.0:attribute:encoder"
name="urn:oid:1.3.6.1.4.1.5923.1.1.1.10" />
<resolver:AttributeEncoder
xsi:type="SAML2XMLObject"
xmlns="urn:mace:shibboleth:2.0:attribute:encoder"
name="urn:oid:1.3.6.1.4.1.5923.1.1.1.10"
friendlyName="EDIRemployeeNumber" />
</resolver:AttributeDefinition>
More information about the dev
mailing list