Changes to web flow action proposal

Tom Zeller tzeller at dragonacea.biz
Wed Apr 17 18:38:20 EDT 2013


> My testing with scope="prototype" seems to suggest this will help us
> improve the readability of the web flow actions, so I've checked in some
> revisions to the refactoring I did.

I too think that the doPreExecute() method makes Actions more readable.

Why is Action readability related to scope ? Maybe I am misreading.

> With the assumption that beans can be stateful by making them prototypes,
> I added doPreExecute and doPostExecute methods to the
> AbstractProfileAction interface in OpenSAML and experimented using an
> action I ported that has some non-trivial pre-processing checks:
>
> opensaml-profile-impl
>         org/opensaml/profile/action/impl/SchemaValidateXmlMessage.java
>
> I think this is a pretty good end state. Still discussing/debating what to
> do about the documentation, but I have some boilerplate in there now
> replacing the annotations we had.

My first reaction is that I like it.

I have a feeling that doPostExecute() will not be used much.

In Action.do[Pre|Post]Execute(), I wonder how throwing Exceptions
which are caught by the AbstractProfileAction for logging and Event
building would look, especially in regards to Javadoc.


More information about the dev mailing list