Changes to web flow action proposal

Cantor, Scott cantor.2 at osu.edu
Wed Apr 17 17:08:26 EDT 2013


My testing with scope="prototype" seems to suggest this will help us
improve the readability of the web flow actions, so I've checked in some
revisions to the refactoring I did.

With the assumption that beans can be stateful by making them prototypes,
I added doPreExecute and doPostExecute methods to the
AbstractProfileAction interface in OpenSAML and experimented using an
action I ported that has some non-trivial pre-processing checks:

opensaml-profile-impl
	org/opensaml/profile/action/impl/SchemaValidateXmlMessage.java

I think this is a pretty good end state. Still discussing/debating what to
do about the documentation, but I have some boilerplate in there now
replacing the annotations we had.

-- Scott




More information about the dev mailing list