<html><head><meta http-equiv="content-type" content="text/html; charset=us-ascii"></head><body style="overflow-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;"><br><div><br><blockquote type="cite"><div>On May 15, 2024, at 1:26 PM, Cantor, Scott <cantor.2@osu.edu> wrote:</div><br class="Apple-interchange-newline"><div><div>Just to make sure I hadn't missed it, I checked my ECP endpoint with Duo enabled and it worked fine, that is the AuthAPI of course, same code.<br><br>-- Scott<br><br></div></div></blockquote></div><div><br></div>Thanks, that got me to looking one more time at the secretKey definition. And it is not defined twice, the problem was one small typo I've looked at multiple times and not seen. And it was only the IdP on start up that was warning about having those "old" idp.duo.nonbrowser" property names like:<div><br></div><div> idp.duo.nonbrowser.secretKey</div><div><br></div><div>that caused me to decide to rename it to </div><div><br></div><div> idp.duo.oidc.nonbrowser.secretKey</div><div><br></div><div>that introduced my error thru an unnoticed mistype. Should have just left it named as I had it before, and ignored the "warnings" :-)</div><div><br></div><div>(I changed the property name back when I couldn't even get the flow to initiate, before I got the PreAuth bean defined correctly.)</div><div><br></div><div>Now it is working.</div><div><br><div>
<div>--<br>Michael A. Grady<br>IAM Architect, Unicon, Inc.</div><div><br></div><br class="Apple-interchange-newline">
</div>
<br></div></body></html>