Shibboleth v4.1.0 upgrade failure with DuoOIDC plugin for Universal Prompt support

Cantor, Scott cantor.2 at osu.edu
Fri Jun 30 20:35:38 UTC 2023


I checked history and there's no version of the plugin with this bug. The property reference in the source tree is properly backstopped with a default.

> authn/DuoOIDC Flow Descriptor XML is added in conf/authn/general->authn.xml --

Why are you doing that step? There shouldn't be anything suggesting you need to do that under any normal conditions, if something says to do that, we probably need to correct it.

The bug is a mistake in the XML posted in that section of the documentation, so you're following an unnecessary step and the step happens to contain the error.

The underlying definition doesn't have the bug, which is why nobody has noted it. 

-- Scott










More information about the users mailing list