uApprove -- Change Attribute Name Listed

Daniel Lutz daniel.lutz at switch.ch
Fri Jul 28 07:31:03 EDT 2017


Joshua Brodie [28.07.17 05:18]:
> We have had it running for over a year -- but have been getting feedback that the attribute names are too cryptic: cn,
> eduPersonEntitlement etc
> 
> We have a link where users can bounced away to read what the attribute names signify but the masses are still not happy.
> 
> Is there any other potential to map the attribute names top something more non-techie friendly -- without too much
> development?

Note that uApprove is for IdP V2 and is not supported anymore.
IdP V3 has built-in support for user consent.

For both, V2 and V3, you can configure human readable names per attribute in the AttributeResolver configuration.
You need to add <DisplayName> and <DisplayDescription> elements to each <AttributeDefinition>.

In the uApprove manual [1], this is documented at "Customizations / Attribute Names and Descriptions".
The uApprove distribution contains an example attributer-resolver.xml file.

If you use IdP V3, please refer to the documentation at [2] and [3].

You can find examples for various attributes on the following page:

  https://wiki.shibboleth.net/confluence/display/IDP30/Human+Readable+Attribute+Names

If you need the names in English only, you just need those <DisplayName> and <DisplayDescription>
elements specifying 'xml:lang="en"'.

- Daniel



[1] https://www.switch.ch/aai/downloads/uApprove-manual/
[2] https://wiki.shibboleth.net/confluence/display/IDP30/ConsentConfiguration
[3] https://wiki.shibboleth.net/confluence/display/IDP30/AttributeDefinitionConfiguration


More information about the users mailing list