Help with IdP attribute configuration

Peter Schober peter.schober at univie.ac.at
Fri Jul 18 13:13:54 EDT 2014


* Nate Klingenstein <ndk at internet2.edu> [2014-07-18 19:00]:
> This is putting it into an attribute, not a NameID, hence no such
> DEBUG message. The attribute (or nameFormat) is wrong, of course, as
> "ImmutableID" clearly is not a URI, btw.
> 
> This, unfortunately, seems to depend on how you define "wrong".  See:
> 
> http://msdn.microsoft.com/en-us/library/azure/jj205463.aspx

No, sorry. There is no suggestion or requirement to release an
attribute with nameFormat of URI and the attribute name of
"ImmutableID".  The above referenced document only talks about
encoding "ImmutableID" into a persistent NameID.

What was wrong was the OP's use of a "basic" attribute name together
with an URI nameFormat, even this is irrelevant for the simple test
with his "dummy SP". Hence my "btw" at the end.

Also I maintain that an attribute defintion with URI nameFormat and
"ImmutableID" as attribute name is wrong (without quotation marks) by
the meaning of those two concepts alone, and is wrong in all possible
worlds, i.e., it'd still be wrong even if Microsoft documented its use
that way, which they don't/didn't above.
-peter


More information about the users mailing list