<div dir="ltr"><div style>Joshua Bloch wrote in the first edition of Effective Java, (c) 2001: "There is little consensus as to whether acronyms should be uppercase or have only their first letter capitalized. While uppercase is more common, a strong argument can be made in favor of capitalizing only the first letter. Even if multiple acronyms occur back-to-back, you can still tell where one word starts and the next word ends. Which class name would you rather see, HTTPURL or HttpUrl?"</div>
<div style><br></div><div style>I'd say that since 2001 there's more consensus on preferring HttpUrl over HTTPURL.</div><div><br></div>SamlBindingContext seems to be the consensus here: <a href="http://stackoverflow.com/questions/1176950/acronyms-in-camel-back">http://stackoverflow.com/questions/1176950/acronyms-in-camel-back</a> , and the advice here: <a href="https://blogs.oracle.com/tor/entry/code_advice_3_don_t">https://blogs.oracle.com/tor/entry/code_advice_3_don_t</a> , and the example Java naming conventions in Wikipedia: <a href="http://en.wikipedia.org/wiki/Naming_convention_(programming)#Java">http://en.wikipedia.org/wiki/Naming_convention_(programming)#Java</a> , and the AmbySoft coding convention ( <a href="http://www.ambysoft.com/downloads/javaCodingStandards.pdf">http://www.ambysoft.com/downloads/javaCodingStandards.pdf</a> , 1.3 # 7).<div>
<br></div><div style>Some IDEs may provide shortcuts that work for HttpSoapDecoder, but not HTTPSOAPDecoder, cf. <a href="http://stackoverflow.com/questions/2236807/java-naming-convention-with-acronyms">http://stackoverflow.com/questions/2236807/java-naming-convention-with-acronyms</a> , IDE shortcuts relying upon CamelCase also mentioned in the Wikipedia article.</div>
<div style><br></div><div style>Hope this helps,</div><div style><br></div><div style>Andrew</div><div style><br></div><div style><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, May 16, 2013 at 10:21 PM, Brent Putman <span dir="ltr"><<a href="mailto:putmanb@georgetown.edu" target="_blank">putmanb@georgetown.edu</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Tom reminded me that after the last dev call I was supposed to start a<br>
thread to discuss this issue and bring it to a vote. So here it is.<br>
<br>
In terms of my opinion, I think that:<br>
<br>
1) We should adopt a consistent convention, both within and between our<br>
(new V3) projects.<br>
<br>
2) If there is evidence for a "Java standard" here, that should probably<br>
inform what we do. Our cursory look at the JavaBeans spec seemed<br>
uncover that it is a little ambiguous on this point; I think we should<br>
probably research a little further before declaring there isn't an<br>
official position.<br>
<br>
3) We've got work to do either way. Perhaps more with one decision than<br>
the other. However, we're talking about mechanical "easy" work (as<br>
opposed to work that requires real thought), and in either case I doubt<br>
it's more than a couple of dozen-ish man-hours, presumably to be split<br>
up amongst several people. So my $.02 is that we shouldn't base the<br>
decision on the perceived amount of work involved, but rather on what we<br>
think is "right".<br>
<br>
4) I don't have a strong aesthetic opinion either way. Like Scott my<br>
initial inclination was to say that acronyms are more naturally all<br>
uppercase, b/c they just are. However, it does look bad when you have 2<br>
or more in a row. Since we've been using the camel case for the new<br>
stuff for quite awhile now, I've grown used to it also, and at this<br>
point I don't think it looks unusual or unnatural. It is in fact<br>
somewhat easier on the eyes.<br>
<br>
5) Don't forget this issue pertains not just to method names but also<br>
class names (e.g. HTTPSOAP11Decoder, SamlBindingContext).<br>
<br>
<br>
So discuss away.<br>
<br>
--Brent<br>
<br>
<br>
<br>
--<br>
To unsubscribe from this list send an email to <a href="mailto:dev-unsubscribe@shibboleth.net">dev-unsubscribe@shibboleth.net</a><br>
</blockquote></div><br></div>