Scriptable DataSealerKeyStrategy Question
Cantor, Scott
cantor.2 at osu.edu
Thu Oct 17 13:37:52 EDT 2019
On 10/17/19, 1:18 PM, "dev on behalf of Snyder, Bill" <dev-bounces at shibboleth.net on behalf of bpsnyder at amazon.com> wrote:
> If I include the p:updateInterval attribute on the bean, I get the following exception during servlet initialization:
The old code can't handle the newer Duration types. We probably used longs before with a @Duration annotation we defined to handle the conversions. I didn't consider that but it's a consequence of the backport.
> While I'm certainly open to trying more things or other scripting engines, I fear that the flexibility/extensibility that
> the scripting based solution is intending to provide is actually making things more difficult for anything but the
> simplest use cases. These issues, coupled with the fact that we still need to define our own bean inside of the global-> system.xml file, lead me to believe that writing a custom java class that implements DataSealerKeyStrategy is much
> simpler and more straight forward. If anyone has any thoughts of suggestion, I'm all ears.
If Jython's that broken that's definitely disappointing. I don't think anything related to node.js is relevant, but that doesn't mean there are workarounds there either. Nashorn is awful, and I tend to use Rhino, but I don't think it would make much difference. I only know how to reference Java code from them, not other javascript. I would definitely think that has to be embedded inline to work.
Java's fine, but that just means it will be a third party extension jar (and whatever other jars are needed) to add to the system. What people choose to add to their local deploys is not a concern of ours as long as they understand any conflicts introduced aren't things we can necessarily resolve.
In any case, that API is the same, AFAIK, between V3 and V4. There are issues such as the Duration thing that will be internal to the plugin, so I doubt it will be a final end state to have the same code working with both, but the changes would be pretty minor.
-- Scott
More information about the dev
mailing list