reconciling the Reloading Attributes with the Dynamic Attributes
Cantor, Scott
cantor.2 at osu.edu
Tue May 8 17:44:03 EDT 2018
> But you said "the dynamic ones don't refresh per se" so I'm confused.
I was speaking loosely, refresh in the sense of when it decides to go ask again.
> Either the refreshDelayFactor attribute on the dynamic provider is misnamed
> or the minCacheDuration/maxCacheDuration attributes are misnamed.
> There's a glaring mismatch here.
You'll have to take that up with Brent, I don't get much into arguments over names, it's all the same to me as long as it's reasonable. What it's doing in the end is still refreshing, it's just the mechanics that are different. I didn't find it that confusing.
> What if all four of the HTTP Caching Attributes were deprecated? Since
> caching is covered quite nicely in the HttpClientConfiguration topic, [1] the
> HTTP Caching Attributes are merely convenience attributes. In the vast
> majority of cases, they probably shouldn't be changed anyway, so they turn
> out to be less than convenient, I think.
I really am not all that familiar with them but auto-wiring up HttpClient objects with default settings is indeed not a terribly useful thing in practice and likely causes more problems than it solves as soon as you have to override a setting they don't cover, so that's probably a reasonable idea, given that there's a bit of code behind them that could be thrown out at some point.
-- Scott
More information about the dev
mailing list