new syntax for RequiredValidUntil filter

Cantor, Scott cantor.2 at osu.edu
Tue Feb 14 10:26:19 EST 2017


> Two answers
>  - The default value of nothing meaning do nothing sucks.  This doesn't need
> a change, it just sucks

I can buy that; given that it's silly and nobody's likely to have that in use, a 4.0 change to the default meaning should be ok.

>  - It is an edge case but it has bitten us more than once (we misremember in
> a support call or even in a bug fix that "this is the
> funky outlier").  We need to move to a position in which durations much be
> durations or milliseconds and the only way to make that
> happen and not break people is to migrate through a changed setting.

That's fair, I was just confirming my understanding.

It isn't out of the realm of the possible that we just document this as a 4.0 change and make the change then from seconds to milliseconds for numeric values that nobody should be using anyway.

Do we get the chance to warn on Duration fields being set by numeric input? I think not because of how Spring works, just checking.

> I'll happily entertain either ways of fixing this (like "just change it to a
> duration in V4 and break people who didn't migrate when
> they got the warning to move away from seconds").   I didn't get any
> feedback in the case so I just went ahead with my proposal,
> doesn't mean it cannot easily be backed out.

It is a Duration now, though, isn't it? I'm setting it with that syntax in 3.3 (and going back to older versions).

> That latter suggestion of mine has the advantage of not forking the
> federation's documentation which does feel like a big win.
> Maybe that's the thing to do?

I think that's what I suggested above. I don't think it's a big deal, though I think being able to warn on numeric input is also useful if I'm wrong and it's possible.

-- Scott



More information about the dev mailing list