new syntax for RequiredValidUntil filter
Rod Widdowson
rdw at steadingsoftware.com
Tue Feb 14 09:56:31 EST 2017
> Then why not start over and introduce a brand new filter:
> RequiredValidUntilThatMakesSense
>
> (I'm kidding about the filter name but the rest is a real suggestion)
>
> As you know, checking validUntil is an essential part of the metadata security model. We shouldn't dance around security for
historical
> reasons.
I'd not argue with that, but (as always) I'd defer to Scott. It would save a whole bunch of soul searching around the current mess.
This is one of the reasons I throw in the documentation asap - to engender discussions.
Anyone have a sensible suggestion for a name ?
<ValidUntilRequired/> perhaps? And in V4 we could swap the meaning so that its always on and you'd need to explicitly say
<ValidUntilRequired maxValidity="PT0S"/> to turn it off?
(usual disclaimers about future discussions not being a commitment &c &c &c)
/r
More information about the dev
mailing list