Memcached StorageService
Marvin Addison
marvin.addison at gmail.com
Mon Sep 29 15:38:36 EDT 2014
> I guess it depends what scenario would be affected by the performance hit,
> but like I said, the straight update() call definitely doesn't need to
> return it, I can change that.
Ok, I think we may have a compromise:
- Change update() methods to return boolean
- Keep updateWithVersion() unchanged
I can do the extra read to get the version in the updateWithVersion
case, but since it's not the common case in the IdP
(StorageBackedIdPSession) it presumably won't have a dramatic impact.
> I can't think of a good name for updateWithVersionReturnBoolean,
> plus the method proliferation is a bit nuts already.
I think we can and should try to avoid method bloat. The API is clean
and complete as-is.
Thanks for working with me on this.
Best,
M
More information about the dev
mailing list