net.shibboleth.utilities.java.support.component.*
Rod Widdowson
rdw at steadingsoftware.com
Tue Feb 18 04:26:43 EST 2014
> Actually, I was thinking that IdentifiedComponent and
> IdentifiableComponent would provide setId() and getId(). I thought it
> made sense for the getter and setter interface names to begin with the
> name of the field, "id".
I chose Nameable so as to not confuse us. I always find naming difficult
which puts me in mind of Humpty Dumpty
> '"When _I_ use a word," Humpty Dumpty said, in rather a scornful tone, "it
means just what I choose it to mean—neither more nor less.
So I'll go with what the group decides. People with opinions should chip in
now, but just for clarity you want
Identified to carry 'setId()'
Identifiable to carry 'getId()'
Not the other way around?
Rod
More information about the dev
mailing list