Adding new Attribute Interfaces to java-api.

Tom Zeller tzeller at dragonacea.biz
Thu Sep 26 15:53:56 EDT 2013


>>Brent :
>>So I had the same discussion with Chad.  That's a pretty accurate basic
>>summary.  His reasoning to me was basically: if you're only ever going
>>to have 1 impl of the interface, then there's no value in the additional
>>complexity of interface + impl, vs just a concrete.  That's pretty much
>>what it boils down to.

> Scott :
> Where it's not as comfortable IMHO are the various plug points inside the
> resolver and filter. I still think they should be interfaces.

How about adding ResolverPlugin, AttributeDefinition, and
DataConnector interfaces, but not AttributeResolver and
AttributeFilter, for now.

Rather than renaming BaseResolverPlugin, BaseAttributeDefinition, and
BaseDataConnector to match our convention that Base* classes do not
implement an interface, I'll propose that we relax that convention
further.

In another thread, apologies for mixing them, I suggested using the
"IdP" prefix for interfaces, but after further review I do not like
that very much in idp-attribute-resolver-api.

Not sure what the plan is for PrincipalConnectorDefinition at the
moment, but it too could extend ResolverPlugin.


More information about the dev mailing list