Attribute/IdPAttribute
Cantor, Scott
cantor.2 at osu.edu
Wed Sep 25 21:27:54 EDT 2013
On 9/25/13 9:19 PM, "Tom Zeller" <tzeller at dragonacea.biz> wrote:
>
>How about a convention that interfaces in the IdP are named of the
>form "IdP<Type>", meaning add IdPAttribute and IdPRequestedAttribute
>as interfaces, as well as IdPDataConnector and IdPAttributeDefinition,
>and I guess IdPAttributeResolver and IdPAttributeFilter if we think
>so.
I can think of one that wouldn't read too well (ServiceSession), but it
doesn't seem to have a great name regardless.
Regarding the others you mention, that's not actually so crazy because my
SP has both a resolver and filter too, not to mention anyway that what
those resolve and filter in the IdP would actually be "IdPAttribute"
anyway. It probably is less about convention there and more about just
being accurate.
>Maybe these interfaces will ease upgrades, maybe we provide a default
>implementation to map selected interfaces from v2 to v3.
I think extension compatibility is very low on the list of things we want
to care about. Scripting is where we have issues.
>We probably should then rename classes like BaseAttributeDefinition to
>DefaultAttributeDefinition implementing IdPAttributeDefinition.
I think we've used Base* before to be the abstract base class for things
implementing an interface, so don't know if that needs to change.
"Default" seems like a concrete thing.
-- Scott
More information about the dev
mailing list