Adding new Attribute Interfaces to java-api.

Daniel Fisher dfisher at vt.edu
Mon Sep 23 21:54:05 EDT 2013


On Mon, Sep 23, 2013 at 12:11 PM, Cantor, Scott <cantor.2 at osu.edu> wrote:
> On 9/23/13 12:03 PM, "Rod Widdowson" <rdw at steadingsoftware.com> wrote:
>
>>In most cases the Interface would collect most of the methods and inherit
>>the name currently used by the definition.  The definition would then
>>become
>>BaseXXXX (or, if not abstract ConcreteXXX - unless anyone has a better
>>name
>>for this case)
>
> I tend to use Basic, Simple, or something else that's descriptive of the
> nature of the implementation.
>

I like Default, but also don't find any of these particularly descriptive.
As always, whatever the naming becomes, consistency across the
projects helps more than the actual name itself.

--Daniel Fisher


More information about the dev mailing list