Discussion and voting: Coding convention : getLdapUrl or getLDAPURL ?
Brent Putman
putmanb at georgetown.edu
Thu May 16 22:21:11 EDT 2013
Tom reminded me that after the last dev call I was supposed to start a
thread to discuss this issue and bring it to a vote. So here it is.
In terms of my opinion, I think that:
1) We should adopt a consistent convention, both within and between our
(new V3) projects.
2) If there is evidence for a "Java standard" here, that should probably
inform what we do. Our cursory look at the JavaBeans spec seemed
uncover that it is a little ambiguous on this point; I think we should
probably research a little further before declaring there isn't an
official position.
3) We've got work to do either way. Perhaps more with one decision than
the other. However, we're talking about mechanical "easy" work (as
opposed to work that requires real thought), and in either case I doubt
it's more than a couple of dozen-ish man-hours, presumably to be split
up amongst several people. So my $.02 is that we shouldn't base the
decision on the perceived amount of work involved, but rather on what we
think is "right".
4) I don't have a strong aesthetic opinion either way. Like Scott my
initial inclination was to say that acronyms are more naturally all
uppercase, b/c they just are. However, it does look bad when you have 2
or more in a row. Since we've been using the camel case for the new
stuff for quite awhile now, I've grown used to it also, and at this
point I don't think it looks unusual or unnatural. It is in fact
somewhat easier on the eyes.
5) Don't forget this issue pertains not just to method names but also
class names (e.g. HTTPSOAP11Decoder, SamlBindingContext).
So discuss away.
--Brent
More information about the dev
mailing list