What is the "Other party" in Attribute Handling called?
Rod Widdowson
rdw at steadingsoftware.com
Thu Feb 21 13:33:52 EST 2013
During the developer's face to face last week we discussed the issues around
the correct naming of the various parties inside OpenSAML. InboundIssuer /
PeerEntity . Provider / Presenting Entity and so forth - see
https://wiki.shibboleth.net/confluence/display/OS30/Messaging+Abstractions+D
iscussion+Document for details. The bottom line is that we need to be
careful about what we call these things.
We also decided that the Attribute Resolver and Attribute Filters should not
use context navigation to access the "other fields" it occasionally needs
("Principal", "my EntityId" and "your EntityId"); rather these should just
reside as standard beany elements in the AttributionResolutionContext and
AttributeFilterContext and be injected into them with a special stage early
on the attribute-resolution or attribute-filter web-flow.
As I come to make the changes for this last I realize that it too is subject
to the "be careful what you call them" rule. So I am polling (mostly Scott
and Brent) for ideas as to what these should be called so as to be both
informative and correct.
Principal is easy, but we are somewhat divorced from SAML at this stage so
"localEntityID" or "SPEntityID" seems wrong at any number of levels.
Ideas?
/Rod
More information about the dev
mailing list