testbed out of sync ?
Tom Zeller
tzeller at dragonacea.biz
Wed Dec 18 14:38:52 EST 2013
>>> My mistake, just change classRef to method.
>>
>>Ah, I am not used to c-namespace named constructor arguments, thx.
>
> That's probably a good argument for using c:_0 instead, which isn't
> dependent on the name. For single argument ctors, that's probably superior.
I guess I propose we continue to use named constructor arguments in
the c-namespace, meaning c:namedArgument="..." rather than c:_0="...",
because the Spring docs suggest that the use of argument indexes is
for rare cases, and because I am feeling like "c:_0" is less readable
than "c:namedArgument", being sensitive to us, um, programming in XML
and the common complaint that such XML is difficult to navigate.
The counter argument is that using argument indexes, meaning c:_0, is
safer when refactoring, which I think is probably true. I hope we find
a suitable tool to help us manage refactoring across Java and Spring
bean definition files, maybe Eclipse STS, as I have mentioned.
More information about the dev
mailing list