OpenSAML dependency on Velocity breaks application

Brent Putman putmanb at georgetown.edu
Fri Apr 27 20:02:56 BST 2012



On 4/27/12 7:25 AM, Tom van den Berge wrote:
>
> I think it would be far better to have this optional in OpenSAML
> itself though. Duplicating code is a major sin ;)
>

Note that you don't have to literally copy/duplicate code to do this. 
You can just extend the DefaultBootstrap class and override the
initializeVelocity() method to be a no-op.  Then invoke that bootstrap
subclass instead of ours.

That said, I agree that it's not optimal for us to initialize Velocity
like that.  We probably can't fix this for v2, since we aren't planning
on anything but patch releases for that going forward.  But if you'd
like to file a Jira issue against v3, we can examine whether we can
rework how we use Velocity to avoid the static init.  It would actually
be more crucial to fix it there, because the custom bootstrap workaround
won't be there in v3, the library init there is very different.

Thanks,
Brent





More information about the dev mailing list